Global Information System (GIS)
Objectives and Overview
You recently recorded the geographic locations of trees on campus using GPS technology. This
week you will work through an exercise to learn how to use ArcMap (part of ArcGIS), a
computer program that allows you to analyze data in a spatial context, and then use the tree data
from Trinity campus to ask spatially relevant ecological questions.
Background I: Habitats and GIS Analysis
Habitat loss is considered to be the primary threat to the biodiversity of our planet. Habitat loss
can be complete, for example burning a section of rainforest to plant crops, or more subtle, but
with the same effects. Even smaller habitat alterations may change the ecological conditions
critical to the species filling niches within that system, causing problems in survival and
reproduction. The question for land management thus becomes not only how much land needs to
be protected, but what are the characteristics of the land that will make it a usable habitat. GIS is
a powerful tool for land management because it allows researchers to view grand-scale landscape
patterns that are not easily studied from the ground; and spatial analysis tools allow for complex,
simultaneous, analyses of multiple data sources.
Background II: Golden-Cheeked Warblers (GCW)
An example of how habitat conversions are impacting individual species is illustrated by the
decline of the golden-cheeked warbler. The golden-cheeked warbler is one of the endangered
species here on the Edwards Plateau - and breeds nowhere else in the world. Its habitat has
decreased in size and become fragmented by land development, agriculture, and highway and
reservoir construction. The Texas Parks and Wildlife Department has compiled resources that
describe this species and its habitat requirements; as a background for this lab, please read the
following web pages and the information from Texas Parks and Wildlife.
https://www.allaboutbirds.org/guide/Golden-cheeked_Warbler/overview
http://tpwd.texas.gov/publications/pwdpubs/media/pwd_bk_w7000_0013_golden_cheeked_warb
ler.pdf
https://tpwd.texas.gov/publications/pwdpubs/media/pwd_bk_w7000_0013_golden_cheeked_war
bler_mgmt.pdf
General Procedures
Today we will use GIS to analyze a hypothetical tract of land in search of suitable habitat regions
for the golden-cheeked warbler to illustrate the power of GIS analysis; and then we will be
analyzing the tree data collected on our campus. Many of the instructions will only make sense
when actually in front of the computer, so as a first step, please just skim through the instructions
below.
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Protocol I: Analysis of potential GCW habitat
ArcGIS Desktop is a powerful GIS software for analyzing and displaying spatial data. The
software is installed on some university computer but is not currently installed in general use
computer labs on campus. If you are not working in the library's computer lab, you will likely
need to use VDI to connect to ArcGIS.
OPEN ArcMap
Once you open the program, close the screen that pops up ‘Getting Started’. To open the map
document for this exercise, you must first download to your desktop the folder 'Warbler' from the
Google Drive.
Then navigate within ArcGIS to open the file 'GCWarb221.mxd'
SETUP ArcMap
1)go to Geoprocessing in menu bar, select Geoprocessing Options, Un-click ‘Enable’ under
Background Processing
2) go to Customize in menu bar, select Extensions, and then select all extensions listed in the
menu.
OVERVIEW OF ArcMap TOOLS
The ArcMap Interface
ArcMap allows many layers of the same geography or extent to be viewed at once. Turning
layers on and off and examining attribute tables lets us understand the spatial data for a
given extent. Turn off all the the layers by unchecking the boxes in the Display
window on the left of the screen (Ctrl-clicking on any radio box will select/unselect all
radio boxes). Now turn on only the BexarCountyLine layer, Streams, and the .tif layer
and use the global view tool (see button at right) to see the full extent. You can go back to the
previous extent by going to the Menu Bar, selecting Bookmark, then selecting [Study Area]. On
some computers, this may be the Bookmarks menu → Study Area.
Using the tool buttons on the toolbar
The map appears on the right side of the window, and there is a toolbar that lets you zoom, pan,
select, measure and identify items on the map. Click on the magnifying glass to select it as your
cursor and move over to the Data Frame window. Zoom in on an area of interest by either clicking
on the map location or by clicking and dragging a box around the
feature(s) you would like to zoom in on.
You can go back to the previous map extent using the back arrow button or zoom out using the
minus magnifying glass.
Another useful tool is the Pan tool. It looks like a hand and is used to move across a map when you are
zoomed in. Click on the Pan Tool and drag to move your map around within the data frame just as you
might push a paper map around on a table to get a better look at a desired area.
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Now re-click all the layers in the display window. And then
go to the Tool Bar and click on the Identify tool. The tool is a
blue circle with a white letter “i” in the center. Now click a
feature (a dot) on your map that you would like to see the
associated attributes. The Identify Results window opens (see
example at right). If you are having a hard time clicking on
the exact point, you can use the Identify tool to draw a
rectangle around an object to select it.
Always click back on the black arrow on the tool bar to return to a normal selection cursor.
The Select Features tool on the Tool Bar can be used to select individual features by clicking on
them, holding the Shift key and clicking on several features or dragging to create a box around a
group of features. Try selecting some features. Notice that the selected feature edges are now
highlighted in a bright turquoise blue. De-select the object by clicking outside the feature area.
Saving your work: Now go to the File menu, select Save As, and name your map document
(lastname.mxd), then save it to your personal y: drive. In the future, you may open this project directly by
double-clicking on the .mxd file you have created if the N drive is mounted on the computer you are
working with. The map document directs ArcMap to where the included layer files are located.
Additionally, the map document carries information regarding colors and symbols used, legends and
scale, and tells the application exactly how you left your project the last time you used it — if you save
your changes before closing! To save heartache, save your work often!!!

EXPLORING THE GOLDEN CHEEK WARBLER HABITAT
The map you have opened includes an area of land in the Edwards Plateau where golden-cheeked
warblers have been sighted. Forestry surveyors have recorded the location and several attributes of
individual trees in the study area using GPS devices, like you did in a previous lab. The forested areas in
regions 1–7 are being considered for protection under the endangered species act. Region 8 has been
largely deforested by land developers and invaded by undesirable, aggressive tree species and is no longer
suitable for this endangered songbird. Using what you have learned from the assigned readings on the
golden-cheeked warbler, you will use GIS technology to determine the suitability of the seven habitats for
the warbler.
Turning on and off layers of data:
Considering that the golden-cheeked warbler prefers a habitat including a dense population of Ashe
juniper (Juniperus ashei), how can we tell which of the regions in our study area are suitable based on this
criterion?
•Turn off (uncheck) all the layers except J. ashei, regions 1–8, and the layer ending in “.tif” (this is
the USGS topographical map we’re using as our base map).
✰ 1) Take note of any regions that might have too few Ashe junipers, and decide which region
might be ruled out as a potential GCW habitat. Record this in your report.
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The presence of native hardwoods, such as oaks (genus: Quercus), is also necessary for goldencheeked warbler success.
•Turn off the J. ashei layer and turn on all of the layers of oak species (Q. laceyi, Q. stellata and Q.
texana).
✰ 2) Take note of any regions lacking oaks in your report.
Using Attribute Tables to Sort and Select Data:
Because golden-cheeked warblers make their nests primarily from the shredded bark of Juniperus ashei,
they tend to inhabit regions in which the J. ashei have matured beyond ~20 years. How can we make
determinations about a particular tree’s age if these data have been collected?
•

Turn on the J. ashei layer, then right-click on J. ashei layer in the bar on the left, and select Open
Attribute Table. This table shows the actual data attributed to each of the points in the J. ashei
layer.

•

Take a minute, examine the data. Each column is labeled with a field name. What kinds of data
do we have for this layer?

•

Right-click on the cell where the word AGE appears. This opens a window with some basic tools.
Click Sort Ascending. This will sort the entire column from lowest to highest, by AGE.

•

The golden-cheeked warbler not only requires a dense stand of Ashe junipers, but it also requires
that the trees be at least 20 years old. Scroll down through the column to examine the range of
data. Stop when you get to the trees that are 20 years and older.

Now let’s select the trees that are too young to be prime habitat for the GCW and see where they are on
the map. There are several ways to select map features. We’ll use the attribute table—which we have
sorted by AGE—to select trees that are younger than 20 years old.
•

To select trees, use the cell to the left of the row for each point. Left-click and hold the row for
the oldest tree that’s less than 20. Now, drag your mouse upward to select all the trees that are
less than 20. When you have them selected, those rows should turn bright blue. Now we can
minimize the attribute table and see where the selected trees appear on the map.

✰ 3) Where do the selected trees occur? What inferences can be made from the distribution of the
selected features?
Using the Selection Tool to Select by Attribute:
Golden-cheeked warblers are most likely to choose habitats on steep-sided slopes. How can we
determine where these areas are without opening the attribute table?
--Turn off the J. ashei layer by left-clicking in the check box.
--Turn on the GCWarb layer.
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Now we’ll look at data for Slope. Again using ‘selection’ in the menu bar to show us the data on
the map: Go to menu bar, click on selection → select by attributes. This will open a window.
Choose GCWarbHab as the Layer.
You will see all the field names from this layer listed below, along with various ways to calculate
your selection.
•

Double click on SLOPE_AGL as the field to select from. SLOPE_AGL will appear in the
equation box below. Click “<=”, then click on Get Unique Values to reveal the values in our data.
Double-click “5” to add that data value to the equations. Check that the box below has a validlooking equation.

•Click Verify to make sure the equation is valid. Click Apply to see the selection appear on the map.
✰ 4) What do the selected features represent? What can you infer from the selected trees?
✰ 5) At this point, evaluate which habitats have been ruled out and which can still be considered for
protection as golden-cheeked warbler habitat.

Nearest Neighbor Distances and Patterns of Dispersal:
The golden-cheeked warbler prefers dense tree stands, on average with individuals no further than ~80
feet apart. How can we use spatial statistical tools to determine which regions are not dense enough for
this species?
In order to find differences in stand density, we will use the “Average Nearest Neighbor” tool. This
allows you to calculate a value for each region representing the average distance between any tree and the
nearest neighboring tree within the region. This tool also provides us with a “dispersal pattern” label for
each region. Dispersal patterns allow us to view the degree to which members of a layer are spatially
dependent. In other words, it can tell you how likely you are to find individuals of a specific group near
other individuals of that group. For instance, if the dispersal pattern of a region is considered “clustered”;
we know that if we find one individual of that group, then there is an increased chance that we could find
another member of that group nearby. If the dispersal pattern is considered “dispersed”, then the presence
of an individual from the group in question indicates that our chances of finding another member of that
group within close proximity are reduced. A “random” pattern of dispersal indicates that there is no
detectable spatial relationship within the layer. In this case, if you locate an individual from the group in
question, then you have equal odds of finding or not finding another member of the group close by.
Quantifying spatial relationships is an important first step in recognizing ecological patterns.
The GIS software will also provide you with a statistical significance value for the dispersal pattern. To
refresh your memory, statistical significance is a term used to indicate the likelihood that a relationship is
due to chance. For instance, a significance value of 0.01 denotes that there is only a 1% probability that
the tested relationship was due to chance. A significance level of 0.05 is the accepted value in scientific
research used to reject a null hypothesis.
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✰ 6) While conducting the following analyses, keep in mind what complications can be introduced due to
problems of scale. Even though you are conducting spatial analyses in the same study area, do you get the
same results when comparing the entire study area to the individual regions? How might this complicate
matters for landscape ecologists?
•

Use the Selection → Clear Selected Features tool to clear the current selection.

•

Select the Toolbox icon from the bar.

•

Select Spatial Statistics Tools → Analyzing Patterns → Average Nearest Neighbor.

•

Select as GCWarbHab for Input Feature Class.

•

Check the radio-box for ‘Generate Report’.

•

Click OK. This will run the application window. When the application has finished running, you
will need to open the folder where it was saved. The easiest way to find the location of the saved
file is to copy the file path from the dialog box. For example, it should look like:
c:\Users\tmurphy\…..Results.html. (otherwise, look in the computer’s Documents Folder—>
ArcGIS —> NearestNeighbor_Results).

You should record the dispersal pattern, level of significance, and nearest mean distance to neighbor in
your report, in the format of the table presented below. Now, run this application (Average Nearest
Neighbor) for each of the regions, 1–8. Your data will be saved in the specified file location.
Make sure to look at the points on the map for each region—you should be able to visualize whether the
points in a given region are clustered, random, or dispersed. You should compare your visual impression
with your statistical output to see if they agree.

Region

Dispersal Pattern

Significance Level

Nearest Neighbor Observed Mean
Distance

GCWarbHab
1
…
8

6

✰ 7) Of the remaining habitats, are there any that are not dense enough to be a suitable goldencheeked warbler habitat? How were you able to come to this conclusion?

Moran’s I (spatial autocorrelation) and Age:
Golden-cheeked warblers prefer habitats with mature stands of trees in “motte” formation. A
motte is a copse or small stand of trees on a prairie. Since the Golden-cheeked warbler prefers mature
motte formations, we must analyze the spatial dependency for location and age attributes for each region.
How can we use spatial tools to reveal these relationships between space and age?
We will use a tool called “Moran’s I” to distinguish this relationship. Moran’s I is a complex
statistical equation based on Tobler’s First Law of geography, which states that all things are related; but
near things are more related than far things (Tobler, 1970). Moran’s I calculates spatial autocorrelation,
which is the degree to which like values for a given attribute will be found together in space.
•

In the toolbox window, under Spatial Statistics Tools → Analyzing Patterns → Spatial
Autocorrelation (Moran’s I).

•

For Input Feature Class, enter Region 3.

•

Input Field= AGE.

•

Click radio-box “Generate Report”.

! Click OK. This will run the application window. When the application has finished running, you
will need to open the folder where it was saved (should be in the computer’s Documents
Folder).
Record the dispersal pattern and significance level for region 3’s Moran’s I in a table like
that below.

Also complete these steps again for region 7.
Moran’s I Dispersal Pattern

Moran’s I Significance Level

Region 3
Region 7
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✰ 8) Compare the dispersal patterns for regions 3 and 7. Which one would indicate a stronger spatial
dependency for tree age?
✰ 9) Which one do you think exhibits a more distinct “motte” formation?
Compare the results of regions 3 and 7 Moran’s I analysis with the dispersal patterns indicated in the
“Average Nearest Neighbor” calculations.
✰ 10) Why did the dispersal patterns change?
✰ 11) At this point, which of the habitats would you most strongly recommend for consideration as a
wildlife preserve for the golden-cheeked warbler?

Point Density Analysis (using spatial tools to create new layers of data):
Earlier we discussed the importance of oak trees to the golden-cheeked warbler. This also means
that the warblers would be negatively affected by an epidemic of oak wilt in their habitat. Oak wilt fungus
has killed hundreds of live oaks and Spanish oaks throughout Central Texas and caused property value
losses worth millions of dollars in recent decades. The propensity for these species of trees to exist in
mottes can create favorable conditions for oak wilt invasion. However, areas with greater species
diversity and age distribution are less likely to be negatively impacted by these fungal outbreaks.
How can we use GIS tools to determine which regions would be most susceptible if an outbreak
of oak wilt were to occur in this part of the Edwards Plateau?
In order to locate areas of oak wilt vulnerability, we will use Point Density Analysis to create a
new data layer. This new layer will create “neighborhoods” using a color gradient based on overlapping
points to indicate the zones that would most likely be prone to oak wilt. As you saw earlier while
exploring the attribute tables, each tree has been assigned a value to indicate its level of susceptibility to
oak wilt. By running point density analysis on all of the trees in our study area, we can create these
neighborhoods without first having to sort and select for oak wilt susceptibility.
•

In Arc toolbox, go to Spatial Analyst Tools → Density → Point Density.

•

In the “Input Field” choose “GCWarbHab” to indicate that you want to run the analysis on all of
your points.

•

In the “Population Field” choose “Oak_Wilt_S”.

•

In the “Output Raster” field click on the folder to the right of the field. Select a temporary space
on your personal drive and name your file “OakWiltSus”. (Do not put spaces in the file name!)

•

Click “Save”.
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•

The new file name will appear in the output raster field. Click “ok”.

The new layer will be displayed on your map. Hide the layers for GCWarbHab, and tree species to see the
pattern of wilt susceptibility.
✰ 12) Where is the area of greatest oak wilt susceptibility?
✰ 13) Considering what you have learned about age spatial dependency using Moran’s I, what other
factors do you think might make it difficult to determine which trees are prone to develop oak wilt?
✰ 14) In light of the oak wilt susceptibility patterns in the study area, how might you consider
changing your recommendation to the land management specialists?
✰ 15) Discuss at least two other factors that should be considered before making final decisions about
how these areas will be protected.
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Protocol II: Analysis of Trinity tree data
After completing your exercise on the GCW habitat, you are ready to proceed with an analysis of the tree
data you collected. We will use these data to ask some fundamental questions about this “community of
trees”, such as the number of species, the relative abundance of the species, and some of the spatial
characteristics explored with the golden-cheeked warbler exercise.
Note that we will assume you remember the steps learned in your previous exercise! If you have any
questions while you proceed, please go back and review the instructions.

Obtaining the GIS Data
• create a new map (File: New)'
To open the map document for this exercise, you must first download to your desktop the
folder 'TREES' from the Google Drive.
Then navigate within ArcGIS to open the file ' CampusTrees2019.mxd'
At this point you should see dots for all the trees sampled. On the toolbar select the “identify-tool”
and click on one of the tree symbols. The information it reveals should be familiar to you from
collecting these same data!
Click the layer 'World Imagery' to pull up the base map.
If you restarted ArcMap since you did the warbler exercise, don't forget:

SETUP ArcMap
1)go to Geoprocessing in menu bar, select Geoprocessing Options, Un-click ‘Enable’ under
Background Processing
2) go to Customize in menu bar, select Extensions, and then select all extensions listed in the
menu.
Creating a Visually Compelling Map
One of the powers of GIS is to provide for visually attractive representations of your data. You will turn
in a map of the tree data color coded by species, so you will want to know how to do this.
•

One way to change the symbols for the trees is to double-click on the symbol (actually click the
colored symbol) below the top ‘MasterMerge2019’ name in the layers window and change the
size and or shape of the symbol to something more readable.

•

Double-click on the name ‘MasterMerge2019’’ to open up the layer properties → select the tab
Symbology. Click on “Categories” and “Unique Values”. Select “Species” from the “Value
Field” drop down menu. Double-click on “Add All Values” and then change the “Color Ramp” to
whatever you feel is appropriate. Click “Apply” and then exit the dialog box to see your work.
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What do these color patterns indicate? Are different species randomly distributed? Or do the same species
tend to reside next to each other?
Click on View and Layout View and you will see what a printed map will look like. You can add north
arrows and legends by clicking on the Insert menu. Work with these tools until you have a “publication
quality” map. Export your map for printing (File —> Export Map) later and return to “Data View” (note
this is possible by clicking on the world or page icons in the lower left).
Make sure your map has a north arrow and a scale.
Analysis of Tree Data
As above, repeat the analysis as you did before on Nearest Neighbor Distances of all trees for the whole
of Trinity campus in the layer file ‘MasterMerge2019’. Indicate your conclusions in your report in a table
like that below.
Region

Dispersal Pattern

Significance Level

Trees

Repeat your analysis of spatial autocorrelation on trees (again in MasterMerge2019) asking the following
questions. Report in a in a table like that below.
Are trees that are next to each other more similar in size than trees further away?
Are trees that are next to each other more likely to be oriented in similar ways?
Measurement

Moran’s I Dispersal
Pattern

Moran’s I Significance Level

DBH
Major Axis Size
(Major_Axis)
Height
Major Axis Orientation
(Major_AxisD)

Species Richness and Diversity Measures
There are a number of ways in which you could analyze the number of species here, but the simplest is to
export your data on to an Excel spread sheet.
•

Open the attribute table for the tree data (MasterMerge2019). On attribute table, go to top left of
menu bar: —> Export. Open the folder menu, select ‘Save as Type’ as dBASE 1111Table. This
will export a “dbf” file that you can load into Excel. You will need to save this file to your Y
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drive (to do this hit the icon with a ‘+ symbol on the folder', and navigate to your U drive). After
you press save, when it asks you to save to the current map, select ‘no’.
•

To open your exported data in Excel, you have to follow these steps: Open Excel, Open File,
click Browse, navigate to where you saved the data, IMPORTANT: do not open the .xml file, but
instead click on the bottom right and select ‘All Files’. Then select the dbf (not xml) file you want
to open

•

Count the total number of species present, otherwise known as Species Richness (S). (note that
you should first sort the Excel table by species, and then remove all the cases where the species
was not identified)

•

Calculate the relative abundance of the different species using the “Simpson’s Index of Species
Diversity (D)” as demonstrated below. (note that you should first remove all of the cases where
the same tree (based on tag #) was measured multiple times).

S = Σ number of species
D = Simpson’s Index (D) = 1/ Σ Pi2 (P is the proportion of each species in the sample)
Example: (S = 7 and D = 4.17 in this example)
Pi

Pi2

A

Number in
community
40

0.40

0.16

B

20

0.20

0.04

C

15

0.15

0.0225

D

10

0.1

E

5

0.05

0.0025

F

5

0.05

0.0025

G

5

0.05

0.0025

Total

100

Species

1

0.01

0.24

Note: in this example, there are 100 trees. When you do your calculations, be sure to correctly
input the number of trees and the percentages.
Carbon sequestration:
You can calculate the amount of carbon sequestered in a tree from its DBH using the following formula:
where C is the kg carbon sequestered and D is the DBH
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Use this formula to calculate the total amount of carbon sequestered in the trees we have measured.
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